ServiceImporterPolicyTestInterpreterContext

We all agree that we should write code which is easy to understand and maintain.

Check this out and have fun! 😀
https://projects.haykranen.nl/java/

Maybe, the class names should not be like “ServiceImporterPolicyTestInterpreterContext” either! 😉
Imagine defining a variable of that type:


ServiceImporterPolicyTestInterpreterContext serviceImporterPolicyTestInterpreterContext = new ServiceImporterPolicyTestInterpreterContext();

Now, imagine reading a function with 10 lines of code, full of similar sh*t! More than half the code is not real code! Just garbage!

Now, consider you have a character limit per line: 100. We have to create 2 lines as our line is 140 characters long!! …badly indented, most probably!

In some programming languages, the scope of a code file, which is importing code, can be “poisoned” easily with the code imported from other libraries. that is one of the reasons coders are almost forced to create ridiculously long “self-explanatory” class/function/variable names.

IMHO, e.g. local variables in a small function; we can use reasonably short comprehensible names because we have a good narrow context there.

I love the type inference in beautifully designed languages like Kotlin: https://kotlinlang.org/docs/basic-syntax.html#variables
same code above can be (even if we have that stupid class name):


var ctx = new ServiceImporterPolicyTestInterpreterContext();

Code is much more readible!

Leave a Reply